Jump to content

Recommended Posts

Hi, I'm trying to start playing with the concept of Smart Contracts. I was following the IDE setup tutorial but I have a problem: after installing the Elrond IDE extension I want to setup the workspace with the "Elrond: Setup Workspace" command, however, it fails with the following log:

INFO:installer:Checking user.
CRITICAL:installer:module 'os' has no attribute 'getuid'

I'm on Windows 10, from what I understood getuid can only be used on Mac. What should I do?

Link to post
Share on other sites
  • 2 weeks later...
8 minutes ago, roko06 said:

Hi there, for W10 error code
 

install visual studio code

launch ubuntu vm

install python on ubuntu https://phoenixnap.com/kb/how-to-install-python-3-ubuntu 

Should work 😉

sudo apt install python3-pip
then 
pip install erdpy
Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

×
×
  • Create New...